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Some of the solutions presented in this booklet use techniques that are not included in the current CAT 

curriculum. They are presented here as alternative methods for solving the problems. It is hoped that 

teachers and participants (learners) will look at the methods used and consider using them in their Practical 

Assessment Tasks which, in a sense, are open-ended and where use can be made of techniques not 

included in the curriculum (see Assessment Criteria 6 and 10 of the DBE’s 2017 PAT for Grade 12). 

A: WORD-PROCESSING 

Over the years, there have been numerous studies to show how playing different types of background 

music can influence shopping behaviour. Everything from music volume to tempo can all play a part in how 

consumers spend money and behave in shops. The document file 'Music in Retail Stores' discusses 

some of the issues that owners need to consider. Use word processing features to answer the following 

questions.  

 

1. What is the font size of most of the text in the document? 11 

Method 1: 

Put the cursor anywhere in the body of the document (not a heading). On the “Home” tab in the “Font” 
group the font size of 11 is displayed. 

 

 
 

Method 2: 

Put the cursor anywhere in the body of the document (not a heading). Turn on “Reveal Formatting” by 

clicking on <Shift><F1>. The “Reveal Formatting” window on the right-hand side of the screen shows in 

the “Font” section that the font size is 11 pt. 

 

 

2. How many rows are in the table in the document?  6 

Method 1: 

Select the table by clicking on the symbol top-right of the table (see image below). All the rows will be 
highlighted you will note that there are no rows without borders. Count the number of rows with the eye. 
You will note that there are 6 rows. 
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3. What is the point size of the Art page border? 9 

8.8 

Method 1: 

Put the cursor in the body text. On the “Home” tab, in the “Paragraph” group, in “Borders and Shading” 
select “Page Border”. The size of the Art page border is displayed. 
 

 
 

Method 2: 

In the “Page Layout” tab click on “Page Borders”. The window shown above will open showing the point 

size of the border. 
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Method 3: 

Put the cursor in the body text. Turn on the “Reveal Formatting” feature making sure that the “Section” 

properties are displayed. The properties of the page border are displayed. 

 

 

4. What is the exact width of the centre/middle column in the table? 5.6 

Method 1: 

Select the centre column of the table. The width is displayed in the “Table Tools Layout” tab. 

 

 
 

Method 2: 

Select the centre column of the table. On the “Table Tools Layout” tab select “Properties”. In the “Table 

Properties” dialog box select “Column”. The width of the centre column is displayed. 
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Method 3: 

Select the centre column of the table. Turn on the “Reveal Formatting” feature ensuring that the “Cell” 

properties are displayed. The width of the cells in the middle column is displayed. 

 

 

5. What word in the document is linked to the bookmark 'Extreme'? skateboarders 

Method 1: 

On the “Home” tab, in the “Editing” group, select “Find”. Then select “Go To”. In the drop-down “Find 
and Replace” dialog box select “Bookmark”. The bookmark Extreme is highlighted. Click “Go To” and 
the cursor will move to the linked word which will be highlighted in the text. 
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Method 2: 

Press the function key F5. It opens up the drop-down dialog box “Find and Replace”. Select 
“Bookmark”. The bookmark Extreme is highlighted. Click “Go To” and the cursor will move to the linked 
word which will be highlighted in the text. 

 

 
 

Method 3: 

Press <Ctrl><G>. This opens up the “Find and Replace” dialog box. Select “Bookmark”. The bookmark 
Extreme is highlighted. Click “Go To” and the cursor will move to the linked word which will be 
highlighted in the text. 

 

 

6. How many times is the word 'customers' found in the document? 8 

Method 1: 

On the “Home” tab in the “Editing” group select “Find”. Enter the word 'customers'. In a panel on the left 
the number is displayed and also where it is found. 
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7. What is the width of the spacing between the two columns under the 

heading 'Genre'? 
1.27 

Method 1: 

Put the cursor anywhere in the column text. On the “Page Layout” tab on the ribbon, select “Layout” and 
then “Columns” in the “Page Setup” group. Select “More Columns”. In the dialog box the spacing 
between the columns is displayed. 
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8. What style of page numbering is used in the document? Arrow 2 

Method 1: 

It may be difficult to see the page numbering as the Art page border obscures it a bit. For the purposes 
of this question one can remove the page border.  

To identify the style of page number, on the “Insert” tab select “Page Number” in the “Header & Footer” 

group. Select “Bottom of Page”. Scroll down through the different styles until you find the style used 

which will be highlighted. The name of the style is indicated on the left. 
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9. What is the Webdings decimal character code for the musical notes used 

as bullets in the table? 
175 

Method 1: 

Select text which has been bulleted with a musical note. On the “Home” tab, in the “Paragraph” group, 
select the “Bullets” drop-down box. Select “Define New Bullet”. In the “Define New Bullet” dialog box, 
select “Symbol”. The “Symbol” dialog box opens for the selected symbol. The character code is 
displayed. 
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B: SPREADSHEET 

The Billboard Hot 100 is a chart that ranks the best-performing songs of the United States in any given 

year. Its data, published by Billboard magazine and compiled by Nielsen SoundScan, is based collectively 

on each song's weekly physical and digital sales, as well as airplay and streaming. The database 'Hot100' 

contains some details of all the songs for the period 2001-2012. In the questions below a “solo performing 

artist” is an artist who performs by themselves and so only their name appears in the database as the artist. 

The spreadsheet file called 'BBHot100HitsR1' contains information on the songs which made it into the 

Billboard Hot 100 hits between 2001 and 2016. 

Many of the questions below can best be answered by turning on the filter (under the Data tab). 

 

1. Where the BPM (beats per minute) is given, what is the range (i.e. the 

difference between highest and lowest) of these values? 
110 

Method 1: 

Use the filter feature by clicking on the arrowhead next to the column heading in column H. This will 

cause a drop-down window to be displayed. BPM values will be displayed in ascending order in this 

drop-down list. The lowest value is 82 and the highest value is 192. The difference between these two 

values is 110. 

Method 2: 

Enter the following formula in any empty cell to the right of the data. 

=MAX(H3:H1602) - MIN(H3:H1602) 

When executed this formula will subtract the minimum BPM value in column H (82) from the maximum 

BPM value in column H (192), giving the range of the values (110). 

Method 3: 

Enter the following formula in any empty cell to the right of the data. 

=MAX(H:H) - MIN(H:H) 

This formula differs from that used in Method 2 as it addresses all numeric values in column H – so it 

should be used with caution When executed on the given data this formula will also subtract the 

minimum BPM value (82) from the maximum BPM value (192), giving the range of the values (110). 

Method 4: 

Use the filter feature by clicking on the arrowhead next to the column heading in column H. This will 

cause a drop-down window to be displayed. In the drop-down window deselect the “(Blanks)” option 

right at the bottom of the list and click on “OK”. The values in column H have now been filtered and only 

contain those rows that have a BPM value.  

Sort the values in the column in descending order. The largest BPM value (192) will be at the top of the 

column and the smallest BPM value (82) will be at the bottom of the column. Subtract the smallest value 

from the largest value to get the answer (110). 

Method 5: 
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Sort the values in the column in ascending order. The smallest BPM value (82) will be at the top of the 

column and those rows with no BPM value will be at the end of the column. Scan the column for the 

largest BPM value (192). Subtract the smallest value from the largest value to get the answer (110). 

2. In which year did Kelly Clarkson have the most hits on the Billboard Hot 

100 hits? 
2005 

Method 1: 

Click on the arrowhead next to “Artist” (col D) and then click on “Text Filters” followed by “Equals”. In the 

window that opens enter the words “Kelly Clarkson”. 

 
Click on “OK” and the data will be filtered to give only those rows that contain the name “Kelly Clarkson” 

in the “Artist” field (col D). 

Then click on the arrowhead next to “Year” (col B) and sort the values in either ascending or descending 

order so that it is easier to scan the values. You will note that in 2005 Kelly Clarkson had 4 hits and in all 

other years in which she appeared in the Billboard Hot 100 she had fewer hits. 

Method 2: 

Use can be made of the COUNTIFS function. Using an empty area to the right of the data (say columns 

M and N) enter the value 2001 into cell M5 and the following formula into cell N5: 

=COUNTIFS(D3:D1602, "Kelly Clarkson", B3:B1602, "=2001") 

OR 

=COUNTIFS(D:D, "Kelly Clarkson", B:B, "=2001") 

In cell M6 enter 2002 and in cell N6 enter the following formula: 

=COUNTIFS(D3:D1602, "Kelly Clarkson", B3:B1602, "=2002") 

OR 

=COUNTIFS(D:D, "Kelly Clarkson", B:B, "=2002") 

Continue this process until you have made provision for each of the years 2001-2016. Once completed 

one gets something like the following: 

Year No. 

2001 0 

2002 1 

2003 1 

2004 1 

2005 4 
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2006 2 

2007 1 

2008 0 

2009 3 

 

This table shows that in 2005 Kelly Clarkson had 4 hits; she had 3 hits in 2009, etc. So 2005 is the year 

in which she had the most hits on the Billboard Hits 100. 

Method 3: 

Use can be made of the COUNTIFS function. Use an empty area to the right of the data (say columns N 

and O). In cells N5 to N20 enter the values 2001 to 2016. In cell O5 enter the following formula: 

=COUNTIFS(D:D, "Kelly Clarkson", B:B, N5) 

OR 

=COUNTIFS(D:D, "Kelly Clarkson", B:B, "="&N5) 

OR 

=COUNTIFS($D$3:$D$1602, "Kelly Clarkson", $B$3:$B$1602, N5) 

Copying the above formula down to the other cells from O6 to O20 gives the following set of values: 

Year No. 

2001 0 

2002 1 

2003 1 

2004 1 

2005 4 

2006 2 

2007 1 

2008 0 

2009 3 

 

The above table shows that in 2005 Kelly Clarkson had 4 hits; she had 3 hits in 2009, etc. Scanning the 

table reveals that in 2005 Kelly Clarkson had the most hits on the Billboard Hits 100. 

Method 4: 

A pivot table can also be used to find the solution. To find out more on pivot tables go to any of the 

following: 

 https://exceljet.net/things-to-know-about-excel-pivot-tables 

 www.excel-easy.com/data-analysis/pivot-tables.html  

 www.youtube.com/watch?v=Vx-Fuw46VbY  

 

Select “Pivot Table” in the “Tables” group on the “Insert” tab on the ribbon. 

 

https://exceljet.net/things-to-know-about-excel-pivot-tables
http://www.excel-easy.com/data-analysis/pivot-tables.html
http://www.youtube.com/watch?v=Vx-Fuw46VbY


 

 

 
 

13 

 
Accept the options presented in the window that opens by clicking on “OK”. A new sheet will open. This 

sheet contains a Pivot Table Field List (on the right) which is effectively the list of column headings of the 

main sheet. 

 

Now click on the “Artist” field name and drag it into the area called Row Labels. As you do this you will 

note that the list of artists in alphabetical order is inserted into column A of the newly opened 

spreadsheet. Click on the “Year” field name and drag it into the area called Column Labels. Once again 

the years from 2001 to 2016 are inserted into row 4 of the newly opened spreadsheet. You can also 

place the “Artist” field in Column Labels and the “Year” field in the Row Columns. 

What is now lacking are the data that links the Artists to the Years. 
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The link between Artist and Year is the Title of the song(s). So click on the “Title” field name and drag it 

into the area called Values. As you do this Excel automatically calculates how many titles each artist had 

in each of the BillBoard Hot 100 years. The following table should be created (note that some of the year 

columns have been hidden in this example): 

 

Count of Title Column Labels 
    

Row Labels 2001 2002 2015 2016 
Grand 
Total 

112 1 
   

1 

*NSYNC 1 1 
  

2 

*NSYNC featuring Nelly 
 

1 
  

1 

112 1 
   

2 

2 Chainz 
    

1 

2 Chainz featuring Drake 
    

1 

2 Pac 
    

1 

2 Pistols 
    

1 

3 Doors Down 2 
   

7 

3LW 1 
   

1 

3OH!3 
    

1 

3OH!3 featuring Kesha 
    

1 

From here there are two ways of obtaining the answer: 

 Scroll down to “Kelly Clarkson” in the list of artists and under 2005 you will find that she had 4 

songs in the BillBoard Hot 100 hits. 

 You will note that there are downward pointing arrowheads next to “Row Labels” and “Column 

Labels” (top left of the table). These can be used in exactly the same way as the arrowheads in a 

spreadsheet where the filters have been turned on. So click on the arrowhead next to “Row 

Columns”, deselect “(Select All)”, scroll down and select “Kelly Clarkson”. When you do this you 

should get the following which once again shows that in 2005 Kelly Clarkson had 4 songs in the 
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BillBoard Hot 100 hits: 

Count of 
Title 

Column 
Labels 

           

Row Labels 2002 2003 2004 2005 2006 2007 2009 2010 2012 2013 2015 

Grand 
Total 

Kelly 
Clarkson 1 1 1 4 2 1 3 1 1 1 1 17 

Grand Total 1 1 1 4 2 1 3 1 1 1 1 17 

 

The beauty of using a pivot table is that if you right click on a value, in this case 4, a drop-down list 

opens up. If you then select “Show Details” from this list a new sheet opens up with all the details of the 

4 songs in that year. 

 

Index Year No Artist Title Minutes Seconds 

0498X14 2005 4 Kelly Clarkson Since U Been Gone 3 8 

0492X14 2005 10 Kelly Clarkson Behind Hazel Eyes 3 14 

0475X14 2005 27 Kelly Clarkson Breakaway [Radio Edit] 3 54 

0430X14 2005 72 Kelly Clarkson Because of You 3 38 
 

3. For those songs where the length is given, how long is the longest song? 

Give your answer in seconds, to the nearest second. 
485 

Method 1: 

Sort the duration of each song in descending order by minute (col F) and then by second (col G). Use a 

custom sort as follows: 

 
The song with the longest playtime will be at the top of the data. The song Mirrors by Justin Timberlake 

with a playtime of 8 min 5 sec is the song with the longest playtime. Converting this to seconds give 485 

seconds. 

Method 2: 

One can use the ISBLANK function to test whether a cell is blank. Insert the following formula into cell 

J2: 

=IF(ISBLANK(F2), "", F2*60+G2) 

The above formula tests whether cell F2 is blank, in other words no playtime is given. If it is blank then a 

blank is inserted in cell J2. If cell F2 is not blank then the value in cell F2 (minutes) is multiplied by 60 

and added to the value in cell G2 (seconds) to give the playtime in seconds. This formula should then be 

copied down to all the other cells in column J. 

Sort the data in descending order according to column J. The song with the longest playtime will be at 
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the top of column J. 

4. The number five appears in the title of four songs. What is the title of the 

shortest song in which it appears?  
FourFiveSeconds 

A quick scan of the data in column E (Title) suggests that the question is slightly ambiguous as the 

number “five” could be seen as the word “five” or the numeral 5. This means that one would have to 

search for both the word “five” and the numeral 5. 

Method 1: 

With the filters turned on click on the arrowhead next to the “Title” field and select “Text Filters” and the 

“Contains” from the subsequent drop-down lists. A window opens allowing one to enter criteria as shown 

on the next page. 

 
Notice the use of the “Or” operator as one needs to search for both the numeral 5 and the word “five”. 

Using the AND operator would look for both the word “five” and the numeral 5 in the title. On clicking 

“OK”, 4 rows are identified as containing the numeral 5 or the word “five”, as shown below (only Title, 

Minutes and Seconds columns shown): 

Title Minutes Seconds 

It's Five O'Clock Somewhere 3 52 

5 O'Clock 3 7 

50 Ways To Say Goodbye 3 53 

FourFiveSeconds 3 5 

As the number of titles is small the playtimes can be scanned. The title with the shortest playtime is 

FourFiveSeconds with a playtime of 3:05. 

If the number of titles was large this list could then be sorted in ascending order first by Minutes and then 

by Seconds with the title of the song with the shortest playtime being at the top of the list. 

5. Track number 1 appears most often. Which track number appears the 7th 

most times? 
6 

A quick scan of column I (Track) will show that the values range between 1 and 20 and that there are a 

number of blanks, i.e. where no track number is given. 

Method 1: 

Use can be made of the COUNTIF function. Use an empty area to the right of the data (say columns K 

and L). In cells K4 to K23 enter the values 1 to 20 in ascending order. To facilitate checking later on the 

values 1 to 20 are also placed in column J. In cell L4 enter the following formula: 
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=COUNTIF(I:I, K4) 

OR 

=COUNT($I$3:$I$1602, K4) 

Copy this formula down to cells L5 to L23 will give the following values: 

J K L 

Pos. Track No. 

1 1 132 

2 2 102 

3 3 90 

4 4 67 

5 5 59 

6 6 66 

7 7 83 

8 8 79 

9 9 56 

10 10 56 

If the set of values in columns K (Track) and L (No.) (not column J) are sorted in descending order 

according to the number (column L) the following is obtained: 

J K L 

Pos. Track No. 

1 1 132 

2 2 102 

3 3 90 

4 7 83 

5 8 79 

6 4 67 

7 6 66 

8 5 59 

9 9 56 

10 10 56 

The above shows that track number 6 with 66 appearances is the track with the 7th most appearances. 

Method 2: 

This problem can also be solved using a pivot table by placing the “Track” field in the Row Labels block, 

the “Year” field in the Column Labels block and the “Track” field in the Values block 
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This will produce a table similar to the one on the next page (some columns have been hidden): 

Count of 
Track Column Labels 

      Row Labels 2001 2002 2003 2004 2015 2016 Grand Total 

1 3 5 5 5 
  

132 

2 5 7 4 4 
  

102 

3 11 8 6 5 1 
 

90 

4 5 5 4 2 
  

67 

5 1 2 7 6 
 

1 59 

6 3 2 4 7 
  

66 

7 2 5 5 3 
  

83 

8 2 5 6 6 
  

79 

9 2 5 2 2 
  

56 

10 5 1 2 7 
  

56 

11 3 1 4 4 1 
 

36 

12 4 3 4 2 
 

1 38 

13 5 4 4 6 
  

36 

14 3 7 
 

2 
  

27 

15 5 4 6 6 
  

25 

16 2 3 5 2 
  

27 

17 4 3 7 3 
  

45 

18 3 2 2 5 
  

28 

19 2 5 3 5 
  

35 

20 
 

2 1 3 
  

19 

    
11 

  
29 

(blank) 
       Grand Total 70 79 81 96 2 2 1135 
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One can then either  

 search the values under Grand Total for the 7th largest number; or  

 sort the data in descending order and then get the track number that is number 7 in the resulting 

list. To sort the pivot table simply select one of the cells in the column you wish to sort on and 

click the sort largest to smallest button in the “Sort & Filter” group on the ribbon. 

6. For all the songs where a length is given, what is the average song length? 

Give your answer in seconds, to the nearest second. 
230 

Method 1: 

Insert the following formula into cell J2: 

=IF(ISBLANK(F2), "", F2*60+G2) 

The above formula tests whether cell F2 is blank, in other words no playtime is given. If it is blank then a 

blank is inserted in cell J2. If cell F2 is not blank then the value in cell F2 (minutes) is multiplied by 60 

and added to the value in cell G2 (seconds) to give the playtime in seconds. This formula should then be 

copied down to all the other cells in column J. 

Having obtained the playtime in seconds for each of the songs one can then use a combination of the 

ROUND and the AVERAGE functions to determine the average song length, to the closest second. 

Enter the following formula at the end of column J, say cell J1605 

=ROUND(AVERAGE(J3:J1602), 0) 

The answer given is 230. 

Method 2: 

This problem can also be solved using a pivot table by dragging and dropping the “Minutes” field and the 

“Seconds” field into the Values block. In this instance drag and drop the “Minutes” field for a second time 

into the Values block. You should have something similar to what appears below: 
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Click on the arrowhead next to each of “Count of Minutes” and “Count of Seconds” in the value block. 

On the drop-down list that appears select “Value Field Settings”, followed by “Sum” and then ÖK”. Leave 

the second instance of “Count of Minutes” as it is. 

Assuming that the values of the previous operations were automatically inserted in cells A4, B4 and C4 

you can now enter the following formula in cell D4: 

=ROUND((A4*60+B4)/C4, 0) 

The answer will be calculated as 230. 

7. How many titles by the same artist(s) appear on the Billboard Hot 100 hits 

in two consecutive years? 
138 

The solution focuses on titles by the same artist. In other words we first need to check whether the same 

title appears in consecutive years and then check that where this does happen whether the artist(s) is 

the same. It is possible for the same title to reach the Hot 100 hits but it could be performed by different 

artists. 

The solution to this problem will require the use of a number of additional columns to be used as 

“building blocks”. 

 

Method 1: 

Sort the dataset in ascending order according to Artist, then Title and then Year. This should place 

songs with the same title in alphabetical order one below the other. Where a particular title is sung by 

more than one artist the artists should be placed in alphabetical order one below the other next to the 

correctly ordered song title. Where a particular artist appears more than once then the years in which 

they appear should be in ascending order. 

For example: 

 B C D E 

 Year No Artist Title 
3 2009 87 Britney Spears 3 

4 2010 69 Britney Spears 3 

5 2013 71 Taylor Swift 22 

One can now read through the list noting where the title/artist combination occurs in consecutive years. 

For a list of 1 600 titles this is quite time-consuming. 

Method 2: 

Sort the dataset in ascending order according to Artist, then Title and then Year. This should place 

songs with the same title in alphabetical order one below the other. Where a particular title is sung by 

more than one artist the artists should be placed in alphabetical order one below the other next to the 

correctly ordered song title. Where a particular artist appears more than once then the years in which 

they appear should be in ascending order. 
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For example: 

 B C D E 

 Year No Artist Title 
3 2009 87 Britney Spears 3 

4 2010 69 Britney Spears 3 

5 2013 71 Taylor Swift 22 

The next step will be to check whether consecutive titles and artists are the same and whether the 

difference between the two years is 1. 

The following method makes use of empty columns to the right of the data, say columns J, K, L and M. 

Enter the following formula in cell J4: 

=(E4 = E3) 

The above formula tests whether the title in cell E4 is the same as the title in cell E3. If the titles are the 

same the value in cell J4 will be TRUE otherwise it will be FALSE. Copy this formula down to all other 

cells in column J. 

In the example given above the value in cell J4 will be TRUE as the titles are the same. The value in cell 

J5 will be FALSE as the titles differ. 

Enter the following formula in cell K4: 

=(D4 = D3) 

The above formula tests whether the artist in cell D4 is the same as the artist in cell D3. If the artists are 

the same the value in cell K4 will be TRUE otherwise it will be FALSE. Copy this formula down to all 

other cells in column K. 

In the example given above the value in cell K4 will be TRUE as the artists are the same. The value in 

cell K5 will be FALSE as the artists differ. 

Enter the following formula in cell L4: 

=(B4 - B3) = 1 

OR 

=B4 = (B3 + 1) 

The above formula tests whether the difference between the value in cell B4 and that in cell B3 is 1. If 

the difference is 1 the value in cell L4 will be TRUE otherwise it will be FALSE. Copy this formula down 

to all other cells in column L.  

In the example given above the value in cell L4 will be TRUE as the years differ by 1. The value in cell 

L5 will be FALSE as the years differ by more than 1. 

Now that we’ve ascertained the logical values for the title, artist and years the AND function can be used 

to determine the overall logical value. Enter the following formula in cell M4: 

=AND(J4, K4, L4) 

Copy this formula down to all other cells in column M. 

In the example given above the values of J4, K4 and L4 are all TRUE so the value of cell M4 will be 

TRUE. This is correct as the song with title 3 sung by Britney Spears appeared in consecutive years, viz. 
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2009 and 2010. The value in cell L5 will be FALSE as the values of J5, K5 and L5 are all FALSE. 

Now use the COUNTIF function to count the number of occurrences of the word TRUE in column M. 

Enter the following formula in cell M1603 

=COUNTIF(M3:M1602, "=TRUE") 

The cell will display the value 138 which is the number of titles by the same artist that appeared on the 

Billboard Hot 100 hits in consecutive years. 

Method 3: 

Use the same sorting procedure as given in Method 1. 

In cell J4 enter the following formula which is a combination of all the separate formulas used in Method 

2: 

=AND(D2=D3, E2=E3, B3=B2+1) 

Now count the number of times TRUE occurs in column J using the following formula: 

=COUNTIF(J3:J1602, "=TRUE") 

Or if you insert the formula in a different column you could use 

=COUNTIF(J:J, "=TRUE") 
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C: DATABASE 

NB. Many of the database questions can also be solved by exporting the table as an Excel spreadsheet 

and then using spreadsheet functions. 

The Billboard Hot 100 is a chart that ranks the best-performing songs of the United States in any given 

year. Its data, published by Billboard magazine and compiled by Nielsen SoundScan, is based collectively 

on each song's weekly physical and digital sales, as well as airplay and streaming. The database 'Hot100' 

contains some details of all the songs for the period 2001-2012. In the questions below a “solo performing 

artist” is an artist who performs by themselves and so only their name appears in the database as the artist. 

1. How many songs are there in the database? 1200 

Method 1: 

Open the database in Datasheet View. The number of records in the database will be displayed in the 

status bar, bottom left of the screen. In this case there are 1 200 records in the database. 

 

2. What is the title of the song with the longest playtime? Happy People 

Method 1: 

Using the automatic filters provided in Access click on the down arrow to the right of the Play_Time field. 

In the drop-down list select “Sort Newest to Oldest”. The records in the database will be sorted in 

descending order according to the Play_Time field. The song with the longest playtime, viz. Happy 

People by R. Kelly with a playtime of 7:49, will be at the top of the list. If you select “Sort Oldest to 

Newset” it will be at the bottom of the list. 

 
 

Method 2: 

Create a simple query based on the BillBoardHot100 table. The query should include at least the Title 

field and the Play_Time field. Other fields could be included but are not essential. Sort the records in 

descending order by Play_Time. 
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When run, the query will display the following with the same overall result: 

 

3. Of the titles in the database released in 2010 how many had a playtime 

greater than 3:59? 
25 

Method 1: 

Using the automatic filters provided in Access click on the arrowhead to the right of the 

First_Release_Year field. Deselect “(Select All)” and scroll down the list and select “2010”. This will filter 

the records displaying the details of only those songs released in 2010. 

Then click on the arrowhead to the right of the Play_Time field and select “Sort Newest to Oldest”. This 

will sort the songs in descending order according to their playtime. 

Using a manual count will show that 25 songs meet the criteria of being released in 2010 and having a 

playtime longer than 3:59. 

Method 2: 

Create a simple query based on the BillBoardHot100 table. The query should include at least the 

First_Release_Year field and the Play_Time field. Other fields could be included but are not essential. 

Setting the criteria for the First_Release_Year field to 2010 will ensure that only those songs released in 

2010 will be displayed. Sort the Play_Time field in descending order will sort the list of songs in order 

from longest playtime to shortest playtime. 

 

When run, the query will display 98 records of which, by counting, 25 will have a playtime greater than 

3:59. 

Method 3: 

Do as for Method 2 above but add a criteria to Play_Time of “>3:59” 
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When run, the query will display 25 records which will have a playtime greater than 3:59. 

4. Some albums include more than one song that appeared in the Billboard 

Hot 100. In 2003, which album included the largest number of R&B songs 

to have appeared in the Billboard Hot 100? 

Stripped 

Method 1: 

Using the automatic filters provided in Access click on the arrowhead to the right of the 

BillBoardHot100Year field. Deselect “(Select All)” and scroll down the list and select “2003”. This will 

filter the records displaying the details of only those songs that reached the BillBoard Hot 100 Hits in 

2003. 

Then click on the arrowhead to the right of the Genre field. Deselect “(Select All)” and scroll down the list 

and select “R&B”. This will now further filter the records displaying the details of only those R&B songs 

that reached the BillBoard Hot 100 Hits in 2003. 

Lastly sort the Titles of the songs in alphabetical order so that titles with the same name appear next to 

each other. A close inspection of the results will show that the Album called Stripped included the largest 

number of hits songs in 2003. (NB. Some fields have been hidden during the filtering process.) 
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Method 2: 

Create a simple query based on the BillBoardHot100 table. The query should include at least the 

BillBoardHot100Year, Genre and Album fields. Other fields could be included but are not essential. 

Setting the criteria for the BillBoardHot100Year field to 2003 will ensure that only those songs that 

appeared in 2003 will be displayed. Setting the criteria for the Genre field to “R&B” will further select only 

those songs that are classified as R&B songs. 

Finally sort the data alphabetically according to the Album field. 

 

When run, the query will display 22 records satisfying the criteria that they should be R&B songs that 

appeared on the BillBoard Hot 100 hits in 2003. A close inspection of the results will show that the album 

called Stripped included the largest number of hits songs in 2003. 

 
 

Method 3: 
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Create a simple query based on the BillBoardHot100 table. The query should include at least the 

BillBoardHot100Year, Genre and Album fields. Other fields could be included but are not essential. 

In this instance include the Album field twice in the query (see below) as we’re going to do TWO things 

with the values in this field. 

Set the criteria for the BillBoardHot100Year field to 2003. Set the criteria for the Genre field to “R&B”. 

Add Totals to the query by grouping the BillBoardHot100Year field, the Genre field and the first instance 

of the Album field. In the second instance of the Album field count the number of albums and sort in 

descending order. 

 

When run, the query will display the following with the album containing the largest number of hits at the 

top of the list: 

 

Once again the album called Stripped includes the largest number of hits. 
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5. Which solo performing artist appears the most times in the database? Rihanna 

Method 1: 

Create a simple query based on the BillBoardHot100 table. The query should include at least the Artist 

and Title fields. Other fields could be included but are not essential. 

Turn on the groupings/totals and change the function in the Title field to Count – see below: 

 

When run, this query produces the following list showing that Rihanna with 16 hits appears most often: 

 

Method 2: 

Create a report based on the BillBoardHot100 table. Include the Artist and Title fields in the report and 

group the records by Artist. 

Add a calculated field to COUNT the number of Titles per Artist. Click on the “Hide Details” button in the 

“Grouping &Totals” group on the ribbon (see image below) to hide the details in the resulting report. 

 
The report in Design View could look like the following: 
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The grouping and sorting could look like the following: 

 
When viewed the report should look something like the following: 

 

 
The report can now be scanned to find the Artist with the highest number of songs in the BillBoard Hot 

100. 
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The report shows that Rihanna with 16 song titles is the solo performing artist with the highest number of 

song titles in the BillBoard Hot 100. 

 

Method 3: 

This method makes use of a pivot table. For more info on how to create pivot tables in Access have a 

look at the following videos on YouTube:  

 https://www.youtube.com/watch?v=ZgerpTHzQes  

 https://www.youtube.com/watch?v=-HNeqxnmrW0  

Pivot tables are very useful in both Excel and Access for quickly summarising data. Unfortunately 

Access 2016 no longer contains the pivot table functionality so one would need to export the table to an 

Excel spreadsheet and then use the pivot table functionality that is embedded in Excel (see Method 3). 

The second YouTube video shows how one can get around this problem by integrating an Excel 

spreadsheet as an object in an Access database. 

Close all tables, queries, forms and reports. 

Highlight the BillBoardHot100 table. Select the “Create” tab on the ribbon. In the “Forms” group click on 

the arrowhead next to “More Forms” and select “Pivot Table” from the resulting drop-down. A window 

similar to the one shown below will open. If the PivotTable Field List does not appear click on the “Field 

List” option in the “Show/Hide” group. 

https://www.youtube.com/watch?v=ZgerpTHzQes
https://www.youtube.com/watch?v=-HNeqxnmrW0
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In the PivotTable Field List pane click on the Artist field name and drag it to the left of the screen where it 

says “Drop Row Fields Here”. Click on the Title field in the PivotTable Field List pane and drag it to the 

area labelled “Drop Totals or Detail Fields Here”. You should now have something similar to the image 

below: 

 

Now highlight the column headed Title by clicking on the cell containing the word Title. The whole 

column should now be selected. Right clicking on the highlighted column will cause a drop-down list to 

appear. Click on “AutoCalc” and then on “Count”. You should now have something similar to the image 

below: 
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Now click on the “Hide Details” option in the “Show/Hide” group on the ribbon. 

 
This will hide the details and leave you with the following: 
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The above table shows that 50 Cent has had 6 songs in the Hot Hits in the period 2001-2012 while 

Adam Lambert has only had 1. We can now either scan this relatively long list looking for the artist with 

the highest count or we can sort the list in descending order on the “Count of Title” column.  

This is best done by right clicking on the column header, i.e. right clicking on the words “Count of Title”, 

then selecting “Sort” and “Sort Descending” from the resulting drop-down list. Having done this produces 

the following result: 

 

The table is now sorted in descending order and shows that Rihanna with a total of 16 hits is the solo 
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performing artist that  appears the most times in the database. 

Method 4: 

Close all tables, queries, forms and reports. 

Highlight the BillBoardHot100 table. Select the “External Data” tab on the ribbon and in the “Export” 

group click on Excel. Select a suitable place in which to export the resulting spreadsheet, say the 

Desktop and give the file a suitable name. When exporting choose the keep formatting and layout option  

and open the destination file after exporting (see below). 

 
All the records in the database will now have been exported to a spreadsheet and the spreadsheet 

should open. Remember that from now on you are working in an Excel spreadsheet and that there is no 

link between the original Access data and the Excel data. 

In Excel click on the “Insert” tab and then on “Pivot Table” 

 

A window similar to the one below open: 

 

Accept the suggested options by clicking on “OK”. This will then create a new worksheet in the Excel 

spreadsheet and present you with the following: 
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Now click on “Artist” and drag it into the box labelled “Row Labels” (bottom left). Then click on “Title” and 

drag it into the box labelled “Values” (bottom right). This sequence of operations will then give you the 

following which you will note is not dissimilar to the pivot table obtained using Access: 

 

Highlight all the data, excluding the first row containing the column headers and the last row containing a 

grand total and then sort the data in descending order according to the second column of data, the 

column headed “Count of Title”. Having done this the data now displays as shown below once again 

showing that Rihanna has the most titles. 
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D: POWERPOINT 

To answer the questions you should open and view the presentation 'Music Genres'. All text on 

the slides should be clearly visible. 

 

1. What transition is applied to most of the slides in the presentation? Reveal 

Method 1: 

Click on the “Transitions” tab on the ribbon then click on the title slide of the presentation.  

 

Now click on any of the other slides in the presentation. 

 

You will note that the title slide has no transition while each of the other slides uses the “Reveal” 
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transition. 

2. What is the aspect ratio of the slides in the presentation? (Give the letter 

of the correct answer). 

A 4:3 

B 16:9 

C 16:10 

B 

Method 1: 

If you’re using Office 2010 click on the “Design” tab on the ribbon. In the “Page Setup” group click on 

“Page Setup”. A window such as the one shown below will open. 

 
You will note that the slides are sized for an on-screen show with a 16:9 aspect ratio. Therefore, option 

B is the correct answer. 

If you’re using Office 2016 click on the “Design” tab on the ribbon. In the “Customize” group click on 

“Slide Size”.  A drop-down list will open displaying the aspect ratio as 16:9. One can also click on the 

“Customize Slide Size” option which will give one the window displayed above. 

 

3. Each bullet point on the 'Rock Music' slide has two animations applied. 

Name any one of them. 

Wipe 

Wheel 

Method 1: 

Select the Rock Music slide. Click on the “Animations” tab on the ribbon and then on the “Animation 

Pane” in the “Advanced Animation” group. The animation pane will open down the right-hand side of the 

screen. 

Click on any one of the items listed as 2, 3 or 4 or 5, 6 or 7. The type of animation applied will be shown 

in the “Animation” group on the ribbon. If one of 2, 3 or 4 is clicked on the animation is seen to be 

“Wipe”. If one of 5, 6 or 7 is clicked on the animation is seen to be “Wheel”. 
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Also if you hover the mouse over one of the numbers in the Animation Pane a box opens up containing 

information on when the animation occurs, e.g. “On Click” and the type of animation, e.g. “Wipe” 

Method 2: 

Select the Rock Music slide. Click on the “Animations” tab on the ribbon. The ribbon will initially show 

that multiple animations have been applied. Two numbers also appear next to bullet point, these being 

the animations. 

 
 

 

If you click on any of the numbers the type of animation applied is highlighted in the ribbon. 
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4. The 'Jazz' slide has a number of design flaws. The slide can be improved 

by: 

(i)  resizing the image and moving it so that it does not cover any text 

(ii)  fading the image and sending it behind the text 

(iii)  applying three animations instead of two to each bullet point. 

 

Which are correct? (Give only the letter of the correct answer) 

 A Only (i) 

 B  (i) or (ii) 

 C (ii) and (iii) 

 D (i), (ii) and (iii) 

B 

Method 1: 

(i) Resizing the image and moving it to the bottom right corner could improve the overall aesthetics 

of the slide. 

(ii) Recolouring the picture to a lighter colour (fading) and placing it behind the text could be an 

option to improve the overall aesthetics of the slide. 

(iii) Applying three animations instead of two would not be appropriate as the lines of text will still be 

hidden behind the image. In any event having more than one animation is already overkill. 

Of the three possibilities, options (i) and (ii) are the only that could be considered and although they 

could both be applied it would be more appropriate to apply either (i) or (ii). This being the case option B 

is considered to be the most correct answer. 

 

 

 


